Trying to replicate tutorial and failing

I am struggling to replicate what I saw performed in https://www.youtube.com/watch?v=PJxsfOX4MOo

This JS error is happening each time a dense layer is added in all browsers:

static/webworkers/calcChartBase.js:1 Failed to load module script: The server responded with a non-JavaScript MIME type of “text/plain”. Strict MIME type checking is enforced for module scripts per HTML spec.

This causes the histograms to fail to load and makes completing the model impossible.

I tried a clean install and going back to all versions released in May. All of them have the same problem. Yet people are clearly using this. How?

Hi @neilb,
Sorry to hear that you are hitting an issue!

Some followup questions:

  • In which way does it make the model impossible to complete? Is it just missing previews or is the component actually failing?
  • Does it only happen for Dense layers, or also for convolutional?
  • Would you mind sending both the full browser log as well as the terminal log you get if you start the tool as “perceptilabs -v=3”?

We will start looking into it asap after that :slight_smile:

The histograms aren’t loading in the designer or when running it so I have no idea what it’s doing and it sometimes just stops running after a while. Histograms have worked with older versions.

Happens on convolutional too…Console log.txt (444.5 KB) Chrome log.txt (1.1 MB)

Thank you for the logs!

One more question for now, what browser are you using?
I’ll write here as soon as I have an update.

The latest versions of Chrome, Firefox and Edge - it’s the same in all of them

@robertl FYI, tried the new version, no change. Same problem.

I found a work around:
press windows logo+R
“regedit”
find: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes.js
change: Content Type: text/plain
to: Content Type: application/javascript
Reboot the computer…
problem temporarily solved. works on firefox, but not working on chrome.

ref: https://github.com/golang/go/issues/32350

1 Like