The file server isn't available

So I just installed PerceptiLabs and everytime i start it i get logged as a@a.test and i can’t create anything and also my terminal is spammed in that what you can see in “PerceptiLabs: fileserver on port 8011”. Here are logs:

Operations to perform:
Apply all migrations: admin, api, auth, contenttypes, sessions
Running migrations:
No migrations to apply.
PerceptiLabs: Starting
2021-01-14 00:24:03.548668: W tensorflow/stream_executor/platform/default/dso_loader.cc:55] Could not load dynamic library ‘cudart64_100.dll’; dlerror: cudart64_100.dll not found
2021-01-14 00:24:03.548844: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
Performing system checks…

Performing system checks…

System check identified no issues (0 silenced).
January 14, 2021 - 00:24:04
Django version 3.1.5, using settings ‘static_file_server.settings’
Starting development server at http://127.0.0.1:8080/
Quit the server with CTRL-BREAK.
Traceback (most recent call last):
File “c:\users\win10\appdata\local\programs\python\python37\lib\runpy.py”, line 193, in run_module_as_main
main”, mod_spec)
File “c:\users\win10\appdata\local\programs\python\python37\lib\runpy.py”, line 85, in run_code
exec(code, run_globals)
File "c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django_main
.py", line 9, in
management.execute_from_command_line()
File "c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\management_init
.py", line 401, in execute_from_command_line
utility.execute()
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\management_init_.py”, line 395, in execute
self.fetch_command(subcommand).run_from_argv(self.argv)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\management\base.py”, line 330, in run_from_argv
self.execute(*args, **cmd_options)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\management\commands\runserver.py”, line 61, in execute
super().execute(*args, **options)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\management\base.py”, line 371, in execute
output = self.handle(*args, **options)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\management\commands\runserver.py”, line 96, in handle
self.run(**options)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\management\commands\runserver.py”, line 105, in run
self.inner_run(None, **options)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\management\commands\runserver.py”, line 118, in inner_run
self.check(display_num_errors=True)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\management\base.py”, line 396, in check
databases=databases,
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\checks\registry.py”, line 70, in run_checks
new_errors = check(app_configs=app_configs, databases=databases)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\checks\urls.py”, line 40, in check_url_namespaces_unique
all_namespaces = _load_all_namespaces(resolver)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\core\checks\urls.py”, line 57, in load_all_namespaces
url_patterns = getattr(resolver, ‘url_patterns’, [])
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\utils\functional.py”, line 48, in get
res = instance.dict[self.name] = self.func(instance)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\urls\resolvers.py”, line 589, in url_patterns
patterns = getattr(self.urlconf_module, “urlpatterns”, self.urlconf_module)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\utils\functional.py”, line 48, in get
res = instance.dict[self.name] = self.func(instance)
File “c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\django\urls\resolvers.py”, line 582, in urlconf_module
return import_module(self.urlconf_name)
File "c:\users\win10\appdata\local\programs\python\python37\lib\importlib_init
.py", line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 1006, in _gcd_import
File “”, line 983, in _find_and_load
File “”, line 967, in _find_and_load_unlocked
File “”, line 677, in _load_unlocked
File “”, line 1050, in exec_module
File “”, line 219, in _call_with_frames_removed
File “fileserver\urls.py”, line 15, in init fileserver.urls
ModuleNotFoundError: No module named ‘fileserver.api.views.url_reachable’
Performing system checks…

System check identified no issues (0 silenced).
January 14, 2021 - 00:24:04
Django version 3.1.5, using settings ‘rygg.settings’
Starting development server at http://127.0.0.1:8000/
Quit the server with CTRL-BREAK.
[14/Jan/2021 00:24:06] “GET /?token=HrhyWQqtklkqLyhSa52EwVdl36VtUxuayXshT1gPAzo HTTP/1.1” 200 493
[14/Jan/2021 00:24:06] “GET /static/styles/vendors.e2495dec0766c048d0da.css HTTP/1.1” 304 0
[14/Jan/2021 00:24:06] “GET /static/js/0.c40e512886fd2a1f8008.js HTTP/1.1” 304 0
[14/Jan/2021 00:24:06] “GET /static/js/app.2f93ba4ee17b896c07d3.js HTTP/1.1” 304 0
WARNING:tensorflow:From c:\users\win10\appdata\local\programs\python\python37\lib\site-packages\tensorflow_core\python\compat\v2_compat.py:68: disable_resource_variables (from tensorflow.python.ops.variable_scope) is deprecated and will be removed in a future version.
Instructions for updating:
non-resource variables are not supported in the long term
[14/Jan/2021 00:24:06] “GET /kernel_url HTTP/1.1” 200 0
[14/Jan/2021 00:24:06] “GET /fileserver_url HTTP/1.1” 200 0
[14/Jan/2021 00:24:06] “GET /rygg_url HTTP/1.1” 200 0
[14/Jan/2021 00:24:06] “GET /rygg_url HTTP/1.1” 200 0
[14/Jan/2021 00:24:06] “GET /static/img/tutorial-background.ac2e517.png HTTP/1.1” 304 0
[14/Jan/2021 00:24:07] “GET /static/fonts/nunito-sans-v5-latin-600.b56c7e1.woff2 HTTP/1.1” 304 0
[14/Jan/2021 00:24:07] “GET /static/fonts/nunito-sans-v5-latin-regular.9c6a1ff.woff2 HTTP/1.1” 304 0
[14/Jan/2021 00:24:07] “GET /static/fonts/nunito-sans-v5-latin-700.d0b6d0f.woff2 HTTP/1.1” 304 0
[14/Jan/2021 00:24:07] “GET /static/fonts/icomoon.1b9c004.woff HTTP/1.1” 304 0
[14/Jan/2021 00:24:07] “GET /projects/ HTTP/1.1” 200 52
2021-01-14 00:24:07,429 - INFO - :1 - Reporting errors with commit id: 3c1081e655d95731e7fd2c2f58c15f11e2d20285
PerceptiLabs is ready…
2021-01-14 00:24:07,473 - INFO - :1 - Trying to listen to: 0.0.0.0 5000
[14/Jan/2021 00:24:07] “GET /mixpanel/track/?data=eyJldmVudCI6ICJtcF9wYWdlX3ZpZXciLCJwcm9wZXJ0aWVzIjogeyIkb3MiOiAiV2luZG93cyIsIiRicm93c2VyIjogIkNocm9tZSIsIiRjdXJyZW50X3VybCI6ICJodHRwOi8vbG9jYWxob3N0OjgwODAvP3Rva2VuPUhyaHlXUXF0a2xrcUx5aFNhNTJFd1ZkbDM2VnRVeHVheVhzaFQxZ1BBem8iLCIkYnJvd3Nlcl92ZXJzaW9uIjogODcsIiRzY3JlZW5faGVpZ2h0IjogMTA4MCwiJHNjcmVlbl93aWR0aCI6IDE5MjAsIm1wX2xpYiI6ICJ3ZWIiLCIkbGliX3ZlcnNpb24iOiAiMi4yOS4xIiwidGltZSI6IDE2MTA1ODAyNDcuMDk2LCJkaXN0aW5jdF9pZCI6ICJhQGEudGVzdCIsIiRkZXZpY2VfaWQiOiAiMTc2ZmRkMzAwMzQyOWQtMDgzMDMxZjM3OWE0Y2EtMzEzNDZkLTFmYTQwMC0xNzZmZGQzMDAzNTQ4OSIsIiRpbml0aWFsX3JlZmVycmVyIjogIiRkaXJlY3QiLCIkaW5pdGlhbF9yZWZlcnJpbmdfZG9tYWluIjogIiRkaXJlY3QiLCIkdXNlcl9pZCI6ICJhQGEudGVzdCIsIm1wX3BhZ2UiOiAiaHR0cDovL2xvY2FsaG9zdDo4MDgwLz90b2tlbj1Icmh5V1FxdGtsa3FMeWhTYTUyRXdWZGwzNlZ0VXh1YXlYc2hUMWdQQXpvIiwibXBfYnJvd3NlciI6ICJDaHJvbWUiLCJtcF9wbGF0Zm9ybSI6ICJXaW5kb3dzIiwidG9rZW4iOiAiMTQ4MGIyMjQ0ZmRkNGQ4MjEyMjdhMjllMjYzN2Y5MjIifX0%3D&ip=1&=1610580247097 HTTP/1.1" 200 0
[14/Jan/2021 00:24:07] "GET /mixpanel/decide/?verbose=1&version=1&lib=web&token=1480b2244fdd4d821227a29e2637f922&ip=1&
=1610580247092 HTTP/1.1” 200 0
[14/Jan/2021 00:24:07] “GET /mixpanel/track/?data=eyJldmVudCI6ICIkb3B0X2luIiwicHJvcGVydGllcyI6IHsiJG9zIjogIldpbmRvd3MiLCIkYnJvd3NlciI6ICJDaHJvbWUiLCIkY3VycmVudF91cmwiOiAiaHR0cDovL2xvY2FsaG9zdDo4MDgwLz90b2tlbj1Icmh5V1FxdGtsa3FMeWhTYTUyRXdWZGwzNlZ0VXh1YXlYc2hUMWdQQXpvIiwiJGJyb3dzZXJfdmVyc2lvbiI6IDg3LCIkc2NyZWVuX2hlaWdodCI6IDEwODAsIiRzY3JlZW5fd2lkdGgiOiAxOTIwLCJtcF9saWIiOiAid2ViIiwiJGxpYl92ZXJzaW9uIjogIjIuMjkuMSIsInRpbWUiOiAxNjEwNTgwMjQ3LjA5OSwiZGlzdGluY3RfaWQiOiAiYUBhLnRlc3QiLCIkZGV2aWNlX2lkIjogIjE3NmZkZDMwMDM0MjlkLTA4MzAzMWYzNzlhNGNhLTMxMzQ2ZC0xZmE0MDAtMTc2ZmRkMzAwMzU0ODkiLCIkaW5pdGlhbF9yZWZlcnJlciI6ICIkZGlyZWN0IiwiJGluaXRpYWxfcmVmZXJyaW5nX2RvbWFpbiI6ICIkZGlyZWN0IiwiJHVzZXJfaWQiOiAiYUBhLnRlc3QiLCJ0b2tlbiI6ICIxNDgwYjIyNDRmZGQ0ZDgyMTIyN2EyOWUyNjM3ZjkyMiJ9fQ%3D%3D&ip=1&=1610580247099 HTTP/1.1" 200 0
[14/Jan/2021 00:24:07] “GET /app/updates_available/ HTTP/1.1” 200 22
2021-01-14 00:24:07,892 - INFO - server.py:191 - Created coreLogic for network ‘None’
[14/Jan/2021 00:24:12] "GET /mixpanel/engage/?data=eyIkc2V0X29uY2UiOiB7IiRlbWFpbCI6ICJhQGEudGVzdCIsIiRjcmVhdGVkIjogIjIwMjEtMDEtMTNUMjM6MjQ6MTIifSwiJHRva2VuIjogIjE0ODBiMjI0NGZkZDRkODIxMjI3YTI5ZTI2MzdmOTIyIiwiJGRpc3RpbmN0X2lkIjogImFAYS50ZXN0IiwiJGRldmljZV9pZCI6ICIxNzZmZGQzMDAzNDI5ZC0wODMwMzFmMzc5YTRjYS0zMTM0NmQtMWZhNDAwLTE3NmZkZDMwMDM1NDg5IiwiJHVzZXJfaWQiOiAiYUBhLnRlc3QifQ%3D%3D&ip=1&
=1610580252015 HTTP/1.1” 200 0
[14/Jan/2021 00:24:12] “GET /mixpanel/engage/?data=eyIkc2V0IjogeyIkb3MiOiAiV2luZG93cyIsIiRicm93c2VyIjogIkNocm9tZSIsIiRicm93c2VyX3ZlcnNpb24iOiA4NywiJGluaXRpYWxfcmVmZXJyZXIiOiAiJGRpcmVjdCIsIiRpbml0aWFsX3JlZmVycmluZ19kb21haW4iOiAiJGRpcmVjdCIsIiRlbWFpbCI6ICJhQGEudGVzdCIsIiRmaXJzdF9uYW1lIjogIkpvaG4iLCIkbGFzdF9uYW1lIjogIkRvZSIsIiRuYW1lIjogIiIsIiRsYXN0X2xvZ2luIjogIjIwMjEtMDEtMTNUMjM6MjQ6MTIifSwiJHRva2VuIjogIjE0ODBiMjI0NGZkZDRkODIxMjI3YTI5ZTI2MzdmOTIyIiwiJGRpc3RpbmN0X2lkIjogImFAYS50ZXN0IiwiJGRldmljZV9pZCI6ICIxNzZmZGQzMDAzNDI5ZC0wODMwMzFmMzc5YTRjYS0zMTM0NmQtMWZhNDAwLTE3NmZkZDMwMDM1NDg5IiwiJHVzZXJfaWQiOiAiYUBhLnRlc3QifQ%3D%3D&ip=1&=1610580252014 HTTP/1.1" 200 0
2021-01-14 00:24:12,184 - INFO - server.py:191 - Frontend receiver: , Frontend request: setUser
2021-01-14 00:24:12,184 - INFO - server.py:191 - Created coreLogic for network ‘’
2021-01-14 00:24:12,186 - INFO - server.py:191 - User has been set to a@a.test
PerceptiLabs: Waiting for services to listen on these ports:
PerceptiLabs: fileserver on port 8011
[14/Jan/2021 00:24:13] "GET /mixpanel/decide/?verbose=1&version=3&lib=web&token=1480b2244fdd4d821227a29e2637f922&distinct_id=a%40a.test&ip=1&
=1610580252012 HTTP/1.1” 200 0
2021-01-14 00:24:13,478 - INFO - server.py:191 - Frontend receiver: , Frontend request: setUser
2021-01-14 00:24:13,479 - INFO - server.py:191 - User has been set to a@a.test
2021-01-14 00:24:14,205 - INFO - server.py:191 - Frontend receiver: , Frontend request: setUser
2021-01-14 00:24:14,206 - INFO - server.py:191 - User has been set to a@a.test
PerceptiLabs: Waiting for services to listen on these ports:
PerceptiLabs: fileserver on port 8011
PerceptiLabs: Waiting for services to listen on these ports:
PerceptiLabs: fileserver on port 8011

Thanks,

Hi @clking,

As a first question, which version of PerceptiLabs did you install?
Was it perceptilabs, perceptilabs-gpu or pl-nightly?

All the best,
Robert

From that what I remember i installed pl-nightly one.

Ah, that would be the issue then, try installing perceptilabs in a new environment :slight_smile:
The nightly currently has some breaking changes

Okay I’ll try it out!

It really helped,
Thanks!

I’ve just run into the same problem even with creating a new environment. I ran the following:

conda create -n plfeb2 python=3.6
conda activate plfeb2
pip install pl-nightly
perceptilabs

When PL launched i then got a popup in PL saying “The file server isn’t available”. And in the terminal window it repeatedly says:

PerceptiLabs: Waiting for services to listen on these ports:
PerceptiLabs: fileserver on port 8011

Hi @danaf,

The nightly is occasionally quite unstable. If you have the printout from “perceptilabs -v=3” we can take a look and see if it’s something we can do a quick fix on :slight_smile:

this is still an issue for me after installing with pip install perceptilabs in July 2021. any updates on this?

Hi @colinconwell

I just gave my environment setup details in reply to this question. Give it a go and let us know if there are any other issues.

Personally, I wouldn’t use a nightly unless advised by someone at PL to check it out for a specific reason (e.g. to see if it resolves a bug for you).

Thanks for the reference, @JulianSMoore . I deleted my conda environment and reinstalled in the order you suggested (everything, that is, except for the OpenAI Gym files, which seemed unrelated), and I am still receiving the same error. Note: This is after installing with the recommended pip install perceptilabs, as opposed to any of the nightly versions.

The inability to access the file server seems to mean I am also unable to run any of the tutorials. I am operating on a remote linux machine – and can provide specs if the error seems specific.

I am seeing the same error on my fresh install of perceptilabs. Here are the exact steps that I have taken.

  1. Created a new conda env with “conda create -n pl python=3.7”
    2… Activated the new environment “conda activate pl”
  2. Installed perceptilabs “pip install perceptilabs”. Note that I did not use the nightly build like others that have brought up the same issue.
    I noticed during the installation that pip complained about not fulfilling all dependencies and gave as an example that Django 3.2.5 was installed when perceptilabs calls for Django 3.2
  3. Installed the needed version of Django “pip install Django=3.2”
    After all that I ran the command perceptilabs and when the browser window opened I logged in with my credentials. Once on the home page the app displayed the error “The file server isn’t available”.
  4. I stopped perceptilabs and restarted it with the command “perceptilabs -v3”. You can see the detailed log information below. One thing that stood out to me was an error

Error: [WinError 10013] An attempt was made to access a socket in a way forbidden by its access permissions.

Upon checking the javascrupt console in the browser I also saw a number of errors. The first error displayed was:
“Access to XMLHttpRequest at ‘http://localhost:8000/app/updates_available/?token=aLj_Nlg00zeGq9Xsqb6QoPx7Lwz9lQwyqSLDoAHGyFQ’ from origin ‘http://localhost:8080’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.”

This is where I am stuck at this point. I’ve been running into the same javascript and server side error for months now and even with the latest version I am still experiencing the same issue. Any help would be very much appreciated.

Cheers,
Mitch

(pl) C:\Users\christowm>perceptilabs -v3
2021-07-24 16:41:37.490307: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cudart64_110.dll’; dlerror: cudart64_110.dll not found
2021-07-24 16:41:37.490494: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
2021-07-24 16:41:41.346355: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library nvcuda.dll
2021-07-24 16:41:41.882245: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1733] Found device 0 with properties:
pciBusID: 0000:01:00.0 name: GeForce GTX 960M computeCapability: 5.0
coreClock: 1.176GHz coreCount: 5 deviceMemorySize: 2.00GiB deviceMemoryBandwidth: 74.65GiB/s
2021-07-24 16:41:41.885324: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cudart64_110.dll’; dlerror: cudart64_110.dll not found
2021-07-24 16:41:41.888368: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cublas64_11.dll’; dlerror: cublas64_11.dll not found
2021-07-24 16:41:41.891573: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cublasLt64_11.dll’; dlerror: cublasLt64_11.dll not found
2021-07-24 16:41:41.894396: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cufft64_10.dll’; dlerror: cufft64_10.dll not found
2021-07-24 16:41:41.897227: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘curand64_10.dll’; dlerror: curand64_10.dll not found
2021-07-24 16:41:41.900751: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cusolver64_11.dll’; dlerror: cusolver64_11.dll not found
2021-07-24 16:41:41.903498: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cusparse64_11.dll’; dlerror: cusparse64_11.dll not found
2021-07-24 16:41:41.906095: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cudnn64_8.dll’; dlerror: cudnn64_8.dll not found
2021-07-24 16:41:41.906213: W tensorflow/core/common_runtime/gpu/gpu_device.cc:1766] Cannot dlopen some GPU libraries. Please make sure the missing libraries mentioned above are installed properly if you would like to use GPU. Follow the guide at https://www.tensorflow.org/install/gpu for how to download and setup the required libraries for your platform.
Skipping registering GPU devices…
Operations to perform:
Apply all migrations: admin, api, auth, contenttypes, sessions
Running migrations:
No migrations to apply.
PerceptiLabs: Starting
2021-07-24 16:41:45.719683: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cudart64_110.dll’; dlerror: cudart64_110.dll not found
2021-07-24 16:41:45.719871: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
2021-07-24 16:41:45.732621: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cudart64_110.dll’; dlerror: cudart64_110.dll not found
2021-07-24 16:41:45.732803: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
Performing system checks…

System check identified no issues (0 silenced).
July 24, 2021 - 16:41:46
Django version 3.2, using settings ‘static_file_server.settings’
Starting development server at http://127.0.0.1:8080/
Quit the server with CTRL-BREAK.
Performing system checks…

System check identified no issues (0 silenced).
July 24, 2021 - 16:41:47
Django version 3.2, using settings ‘rygg.settings’
Starting development server at http://127.0.0.1:8000/
Quit the server with CTRL-BREAK.
Error: [WinError 10013] An attempt was made to access a socket in a way forbidden by its access permissions
2021-07-24 16:41:49.818533: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library nvcuda.dll
2021-07-24 16:41:49.872022: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library nvcuda.dll
[24/Jul/2021 16:41:49] “GET /?token=aLj_Nlg00zeGq9Xsqb6QoPx7Lwz9lQwyqSLDoAHGyFQ HTTP/1.1” 200 493
[24/Jul/2021 16:41:50] “GET /static/js/0.0f20071dc25e34284782.js HTTP/1.1” 304 0
[24/Jul/2021 16:41:50] “GET /static/styles/vendors.7f3649cffb14be4ffd05.css HTTP/1.1” 304 0
[24/Jul/2021 16:41:50] “GET /static/js/app.9b1964b715450a213b9b.js HTTP/1.1” 304 0
2021-07-24 16:41:50.346737: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1733] Found device 0 with properties:
pciBusID: 0000:01:00.0 name: GeForce GTX 960M computeCapability: 5.0
coreClock: 1.176GHz coreCount: 5 deviceMemorySize: 2.00GiB deviceMemoryBandwidth: 74.65GiB/s
2021-07-24 16:41:50.349161: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1733] Found device 0 with properties:
pciBusID: 0000:01:00.0 name: GeForce GTX 960M computeCapability: 5.0
coreClock: 1.176GHz coreCount: 5 deviceMemorySize: 2.00GiB deviceMemoryBandwidth: 74.65GiB/s
2021-07-24 16:41:50.350491: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cudart64_110.dll’; dlerror: cudart64_110.dll not found
2021-07-24 16:41:50.352239: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cudart64_110.dll’; dlerror: cudart64_110.dll not found
2021-07-24 16:41:50.353520: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cublas64_11.dll’; dlerror: cublas64_11.dll not found
2021-07-24 16:41:50.355360: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cublas64_11.dll’; dlerror: cublas64_11.dll not found
2021-07-24 16:41:50.357092: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cublasLt64_11.dll’; dlerror: cublasLt64_11.dll not found
2021-07-24 16:41:50.359188: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cublasLt64_11.dll’; dlerror: cublasLt64_11.dll not found
2021-07-24 16:41:50.360046: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cufft64_10.dll’; dlerror: cufft64_10.dll not found
2021-07-24 16:41:50.362387: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cufft64_10.dll’; dlerror: cufft64_10.dll not found
2021-07-24 16:41:50.362730: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘curand64_10.dll’; dlerror: curand64_10.dll not found
2021-07-24 16:41:50.365709: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘curand64_10.dll’; dlerror: curand64_10.dll not found
2021-07-24 16:41:50.366665: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cusolver64_11.dll’; dlerror: cusolver64_11.dll not found
2021-07-24 16:41:50.369349: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cusolver64_11.dll’; dlerror: cusolver64_11.dll not found
2021-07-24 16:41:50.371025: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cusparse64_11.dll’; dlerror: cusparse64_11.dll not found
2021-07-24 16:41:50.373141: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cusparse64_11.dll’; dlerror: cusparse64_11.dll not found
2021-07-24 16:41:50.374596: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cudnn64_8.dll’; dlerror: cudnn64_8.dll not found
2021-07-24 16:41:50.375297: W tensorflow/core/common_runtime/gpu/gpu_device.cc:1766] Cannot dlopen some GPU libraries. Please make sure the missing libraries mentioned above are installed properly if you would like to use GPU. Follow the guide at https://www.tensorflow.org/install/gpu for how to download and setup the required libraries for your platform.
Skipping registering GPU devices…
2021-07-24 16:41:50.376084: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘cudnn64_8.dll’; dlerror: cudnn64_8.dll not found
2021-07-24 16:41:50.376641: W tensorflow/core/common_runtime/gpu/gpu_device.cc:1766] Cannot dlopen some GPU libraries. Please make sure the missing libraries mentioned above are installed properly if you would like to use GPU. Follow the guide at https://www.tensorflow.org/install/gpu for how to download and setup the required libraries for your platform.
Skipping registering GPU devices…
[24/Jul/2021 16:41:50] “GET /rygg_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:50] “GET /rendering_kernel_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:50] “GET /kernel_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:50] “GET /keycloak_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:51] “GET /keycloak_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:51] “GET /?token=aLj_Nlg00zeGq9Xsqb6QoPx7Lwz9lQwyqSLDoAHGyFQ HTTP/1.1” 200 493
[24/Jul/2021 16:41:51] “GET /rygg_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:51] “GET /rendering_kernel_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:51] “GET /kernel_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:51] “GET /keycloak_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:52] “GET /keycloak_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:52] “GET /is_enterprise HTTP/1.1” 200 28
[24/Jul/2021 16:41:52] “GET /rygg_url HTTP/1.1” 200 0
[24/Jul/2021 16:41:52] “GET /static/fonts/nunito-sans-v5-latin-600.b56c7e1.woff2 HTTP/1.1” 304 0
[24/Jul/2021 16:41:52] “GET /static/fonts/nunito-sans-v5-latin-700.d0b6d0f.woff2 HTTP/1.1” 304 0
[24/Jul/2021 16:41:52] “GET /static/fonts/nunito-sans-v5-latin-regular.9c6a1ff.woff2 HTTP/1.1” 304 0
[24/Jul/2021 16:41:52] “GET /static/fonts/icomoon.1b9c004.woff HTTP/1.1” 304 0
2021-07-24 16:41:53,820 - INFO - perceptilabs_main_:4 - Started kernel in mode ‘training’
2021-07-24 16:41:53,827 - INFO - perceptilabs_main_:4 - Started kernel in mode ‘rendering’
2021-07-24 16:41:54,683 - INFO - perceptilabs_main_:4 - Reporting errors with commit id: 89e2abc3915ae49d8739c72d32da86ac4c8b85a9
PerceptiLabs is ready…
2021-07-24 16:41:54,720 - INFO - perceptilabs_main_:4 - Trying to listen to: 0.0.0.0 5000
2021-07-24 16:41:54,762 - INFO - :219 - Initialized sentry for environment ‘production’ and release ‘0.12.16’
2021-07-24 16:41:54,870 - INFO - server.py:293 - Frontend receiver: None , Frontend request: checkVersions
2021-07-24 16:41:54,870 - INFO - server.py:293 - Created coreLogic for network ‘None’
2021-07-24 16:41:54,881 - INFO - server.py:293 - Frontend receiver: None , Frontend request: isRunning
PerceptiLabs: Waiting for services to listen on these ports:
PerceptiLabs: kernel on port 5000
2021-07-24 16:41:55,570 - INFO - server.py:293 - Frontend receiver: , Frontend request: setUser
2021-07-24 16:41:55,571 - INFO - server.py:293 - Created coreLogic for network ‘’
2021-07-24 16:41:55,572 - INFO - server.py:293 - User has been set to mitch.christow@gmail.com
PerceptiLabs: PerceptiLabs Started
PerceptiLabs: PerceptiLabs is running at http://localhost:8080/?token=aLj_Nlg00zeGq9Xsqb6QoPx7Lwz9lQwyqSLDoAHGyFQ
PerceptiLabs: Use Control-C to stop this server and shut down all PerceptiLabs processes.

Hi @colinconwell,
Sorry to hear that you ran into an issue.
Unfortunately, the standard pip installation is built for local use only and will run into a series of issues if you try to run it on a remote machine.
Luckily, we have a Docker version that’s built just for this scenario. Let me know if you would be interested in that on instead and we can set up a call :slight_smile:

All the best,
Robert

@christowm,
Seems like your original thread got hijacked, and it looks like we missed the WinError you pointed out here, really sorry about that!
This error typically happens in case a port is already occupied by another process, and would explain a lot of the issue you are having.
If you run this:

netstat -a -n -o | find "8080"
netstat -a -n -o | find "8000"
netstat -a -n -o | find "8011"
netstat -a -n -o | find "5000"

Before you start PL you can see if any processes occupy the ports PL uses. If any do, you need to terminate them.

Hope that finally allows you to proceed and get past the CORS issue :slight_smile:

As to the other curiosity you mentioned with Django, that shouldn’t be an issue but if it is it’s a much easier one to debug and fix.

yes, very interested. using perceptilabs on a remote machine is the only place it makes sense in my case (as it’s where our GPUs are), so a dockerized solution would be excellent!

Awesome, I’ll send you an email later today and we can take it from there :slight_smile:

@robertl thanks for the tip. I finally found a service that was running on port 8000. I feel foolish since I could have sworn that I checked all those ports. However I obviously overlooked this. Now I was able to start perceptilabs without any issues. Thanks for all your help.

Cheers,
Mitch

1 Like