Perceptilabs not opening in browser

Hi
I try to run perceptilabs, but it doesn’t open in the browser…
I checked that port 8080 is free
I ran “perceptilabs -v=3” - attached log
it seems that there is a problem with xdg-open?

thanks for your help!

Hi Naama,
Welcome to the forum!

Just wanted to let you know that we are looking into this now, I’ll post here again as soon as we have any updates.

All the best,
Robert

Hi again,

Did it work if you manually copied the URL into a browser?

Thanks!
Robert

Hi!
no :frowning:
I work on remote machine, so I use the IP of the remote machine in the browser - unfortunately it didn’t work.
I always work on the remote server and another web applications (like tensorboard, streamlit…) work when I use the remote IP in browser.

thank you for your help!
Naama

Unfortunately, the free version is not designed to work on a remote machine.
We do have a Docker version though, if you are interested we could take a call to get things set up.

All the best,
Robert

looks like i am having same issue.

** I run the server on wsl2 **
I could not find the first page for signup which I have seen in youtube tutorial
I saw an alert only with login button
is this means I can not use perceptilabs on wsl2?

this is the page presented when the server started

Hi @dasom,
We have had some issues with WSL in general, but it seems like it starts working if you stop and restart WSL before running PL again (https://docs.perceptilabs.com/perceptilabs/support/perceptilab-faqs#why-does-perceptilabs-fail-to-run-on-wsl).

I have never seen that alert and login before though, that looks like you might also have something already on the port before starting PL.
Try running:
netstat -a -n -o | find "8080"
netstat -a -n -o | find "8000"
netstat -a -n -o | find "8001"
netstat -a -n -o | find "5000"
And kill anything that’s already on those ports before you start PL.

Hope that works!

Hi @robertl

I check those ports before restarting perceptilabs

start perceptilabs

checking those ports

login page doesn’t show up
so i copy url in terminal then paste it to browser

then this log shows up in terminal

finally login page shows up

thank you @robertl

@dasom great that manually going to the website worked!
Just let us know if we can assist with anything else :slight_smile: