'perceptilabs' is not recognized as an internal or external command, operable program or batch file

I have installed perceptilabs on a virtual anaconda environment just like in the start video but when i try to run perceptilabs i get the following error.

‘perceptilabs’ is not recognized as an internal or external command,
operable program or batch file.

Here is the full install output
(base) C:\WINDOWS\system32>conda create -n pl python=3.7
Collecting package metadata (current_repodata.json): done
Solving environment: done

Package Plan

environment location: C:\ProgramData\Anaconda3\envs\pl

added / updated specs:
- python=3.7

The following NEW packages will be INSTALLED:

ca-certificates pkgs/main/win-64::ca-certificates-2021.1.19-haa95532_0
certifi pkgs/main/win-64::certifi-2020.12.5-py37haa95532_0
openssl pkgs/main/win-64::openssl-1.1.1i-h2bbff1b_0
pip pkgs/main/win-64::pip-20.3.3-py37haa95532_0
python pkgs/main/win-64::python-3.7.9-h60c2a47_0
setuptools pkgs/main/win-64::setuptools-52.0.0-py37haa95532_0
sqlite pkgs/main/win-64::sqlite-3.33.0-h2a8f88b_0
vc pkgs/main/win-64::vc-14.2-h21ff451_1
vs2015_runtime pkgs/main/win-64::vs2015_runtime-14.27.29016-h5e58377_2
wheel pkgs/main/noarch::wheel-0.36.2-pyhd3eb1b0_0
wincertstore pkgs/main/win-64::wincertstore-0.2-py37_0
zlib pkgs/main/win-64::zlib-1.2.11-h62dcd97_4

Proceed ([y]/n)? y

Preparing transaction: done
Verifying transaction: done
Executing transaction: done

To activate this environment, use

$ conda activate pl

To deactivate an active environment, use

$ conda deactivate

(base) C:\WINDOWS\system32>conda activate pl

(pl) C:\WINDOWS\system32>pip install perceptilabs
Requirement already satisfied: perceptilabs in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (0.11.7)
Requirement already satisfied: azure-storage-blob==12.6.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (12.6.0)
Requirement already satisfied: azure-eventhub==5.1.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (5.1.0)
Requirement already satisfied: websockets>=8.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (8.1)
Requirement already satisfied: wrapt>=1.12.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.12.1)
Requirement already satisfied: Django>=3.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (3.1.6)
Requirement already satisfied: tensorflow==1.15 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.15.0)
Requirement already satisfied: fsspec>=0.6.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (0.8.5)
Requirement already satisfied: Deprecated>=1.2.10 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.2.11)
Requirement already satisfied: gitdb>=4.0.5 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (4.0.5)
Requirement already satisfied: GitPython>=3.1.8 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (3.1.13)
Requirement already satisfied: certifi>=2020.4.5.1 in c:\programdata\anaconda3\envs\pl\lib\site-packages (from perceptilabs) (2020.12.5)
Requirement already satisfied: PyGithub>=1.53 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.54.1)
Requirement already satisfied: colorama==0.4.3 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (0.4.3)
Requirement already satisfied: boto>=2.49.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (2.49.0)
Requirement already satisfied: pypiwin32>=223 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (223)
Requirement already satisfied: mixpanel==4.7.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (4.7.0)
Requirement already satisfied: boltons>=19.3.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (20.2.1)
Requirement already satisfied: django-http-exceptions>=1.3.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.4.0)
Requirement already satisfied: pydantic>=1.6.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.7.3)
Requirement already satisfied: sentry-sdk==0.14.3 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (0.14.3)
Requirement already satisfied: smmap>=3.0.4 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (3.0.5)
Requirement already satisfied: boto3>=1.9.233 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.17.5)
Requirement already satisfied: django-request-logging>=0.7.2 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (0.7.2)
Requirement already satisfied: greenlet>=0.4.15 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.0.0)
Requirement already satisfied: gputil>=1.4.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.4.0)
Requirement already satisfied: blessings>=1.7 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.7)
Requirement already satisfied: djangorestframework>=3.11.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (3.12.2)
Requirement already satisfied: gym-unity>=0.20.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (0.23.0)
Requirement already satisfied: opencv-python in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (4.5.1.48)
Requirement already satisfied: flask>=1.1.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (1.1.2)
Requirement already satisfied: asgiref>=3.2.10 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (3.3.1)
Requirement already satisfied: mlagents>=0.20.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (0.23.0)
Requirement already satisfied: mlagents-envs>=0.18.0asgiref>=3.2.7 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (0.23.0)
Requirement already satisfied: django-cors-headers>=3.2.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (3.7.0)
Requirement already satisfied: curtsies>=0.3.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (0.3.5)
Requirement already satisfied: sqlparse>=0.3.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (0.4.1)
Requirement already satisfied: pillow==7.0.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (7.0.0)
Requirement already satisfied: psycopg2-binary>=2.8.5 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from perceptilabs) (2.8.6)
Requirement already satisfied: azure-core<2.0.0,>=1.5.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from azure-eventhub==5.1.0->perceptilabs) (1.11.0)
Requirement already satisfied: uamqp<2.0,>=1.2.7 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from azure-eventhub==5.1.0->perceptilabs) (1.2.14)
Requirement already satisfied: msrest>=0.6.10 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from azure-storage-blob==12.6.0->perceptilabs) (0.6.21)
Collecting jsonschema==3.2.0
Downloading jsonschema-3.2.0-py2.py3-none-any.whl (56 kB)
|████████████████████████████████| 56 kB 1.3 MB/s
Requirement already satisfied: setuptools in c:\programdata\anaconda3\envs\pl\lib\site-packages (from jsonschema==3.2.0->perceptilabs) (52.0.0.post20210125)
Collecting scikit-image==0.17.2
Using cached scikit_image-0.17.2-cp37-cp37m-win_amd64.whl (11.5 MB)
Requirement already satisfied: tensorflow-estimator==1.15.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from tensorflow==1.15->perceptilabs) (1.15.1)
Requirement already satisfied: tensorboard<1.16.0,>=1.15.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from tensorflow==1.15->perceptilabs) (1.15.0)
Requirement already satisfied: wheel>=0.26 in c:\programdata\anaconda3\envs\pl\lib\site-packages (from tensorflow==1.15->perceptilabs) (0.36.2)
Collecting gast==0.2.2
Using cached gast-0.2.2-py3-none-any.whl
Collecting urllib3==1.25.10
Using cached urllib3-1.25.10-py2.py3-none-any.whl (127 kB)
Collecting absl-py>=0.7.0
Using cached absl_py-0.11.0-py3-none-any.whl (127 kB)
Collecting astor>=0.8.0
Using cached astor-0.8.1-py2.py3-none-any.whl (27 kB)
Collecting attrs>=17.4.0
Downloading attrs-20.3.0-py2.py3-none-any.whl (49 kB)
|████████████████████████████████| 49 kB 1.1 MB/s
Requirement already satisfied: jmespath<1.0.0,>=0.7.1 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from boto3>=1.9.233->perceptilabs) (0.10.0)
Requirement already satisfied: botocore<1.21.0,>=1.20.5 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from boto3>=1.9.233->perceptilabs) (1.20.5)
Requirement already satisfied: s3transfer<0.4.0,>=0.3.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from boto3>=1.9.233->perceptilabs) (0.3.4)
Collecting chardet>=3.0.4
Downloading chardet-4.0.0-py2.py3-none-any.whl (178 kB)
|████████████████████████████████| 178 kB 3.3 MB/s
Collecting cryptography>=2.8
Downloading cryptography-3.4.4-cp36-abi3-win_amd64.whl (1.6 MB)
|████████████████████████████████| 1.6 MB 6.8 MB/s
Collecting cffi>=1.12
Downloading cffi-1.14.4-cp37-cp37m-win_amd64.whl (178 kB)
|████████████████████████████████| 178 kB 6.8 MB/s
Requirement already satisfied: cwcwidth in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from curtsies>=0.3.1->perceptilabs) (0.1.4)
Collecting dask[dataframe]>=2.6.0
Using cached dask-2021.2.0-py3-none-any.whl (900 kB)
Requirement already satisfied: partd>=0.3.10 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from dask[dataframe]>=2.6.0->perceptilabs) (1.1.0)
Requirement already satisfied: itsdangerous>=0.24 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from flask>=1.1.1->perceptilabs) (1.1.0)
Collecting click>=5.1
Using cached click-7.1.2-py2.py3-none-any.whl (82 kB)
Collecting google-pasta>=0.1.6
Using cached google_pasta-0.2.0-py3-none-any.whl (57 kB)
Collecting grpcio>=1.8.6
Using cached grpcio-1.35.0-cp37-cp37m-win_amd64.whl (3.0 MB)
Requirement already satisfied: gym in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from gym-unity>=0.20.0->perceptilabs) (0.18.0)
Collecting idna>=2.9
Downloading idna-3.1-py3-none-any.whl (58 kB)
|████████████████████████████████| 58 kB 3.8 MB/s
Collecting imageio>=2.3.0
Using cached imageio-2.9.0-py3-none-any.whl (3.3 MB)
Collecting importlib-metadata>=1.7.0
Downloading importlib_metadata-3.4.0-py3-none-any.whl (10 kB)
Collecting jinja2>=2.10.3
Downloading Jinja2-2.11.3-py2.py3-none-any.whl (125 kB)
|████████████████████████████████| 125 kB 6.4 MB/s
Collecting keras-applications>=1.0.8
Using cached Keras_Applications-1.0.8-py3-none-any.whl (50 kB)
Collecting keras-preprocessing>=1.0.5
Using cached Keras_Preprocessing-1.1.2-py2.py3-none-any.whl (42 kB)
Collecting markdown>=3.2.1
Using cached Markdown-3.3.3-py3-none-any.whl (96 kB)
Collecting MarkupSafe>=0.23
Downloading MarkupSafe-1.1.1-cp37-cp37m-win_amd64.whl (16 kB)
Collecting matplotlib!=3.0.0,>=2.0.0
Using cached matplotlib-3.3.4-cp37-cp37m-win_amd64.whl (8.5 MB)
Collecting cycler>=0.10
Using cached cycler-0.10.0-py2.py3-none-any.whl (6.5 kB)
Collecting kiwisolver>=1.0.1
Using cached kiwisolver-1.3.1-cp37-cp37m-win_amd64.whl (51 kB)
Requirement already satisfied: cattrs<1.1.0,>=1.0.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from mlagents>=0.20.0->perceptilabs) (1.0.0)
Collecting h5py
Using cached h5py-3.1.0-cp37-cp37m-win_amd64.whl (2.7 MB)
Requirement already satisfied: isodate>=0.6.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from msrest>=0.6.10->azure-storage-blob==12.6.0->perceptilabs) (0.6.0)
Collecting networkx>=2.0
Using cached networkx-2.5-py3-none-any.whl (1.6 MB)
Collecting decorator>=4.3.0
Downloading decorator-4.4.2-py2.py3-none-any.whl (9.2 kB)
Collecting numpy<1.19.0,>=1.18.5
Using cached numpy-1.18.5-cp37-cp37m-win_amd64.whl (12.7 MB)
Collecting oauthlib>=3.0.2
Using cached oauthlib-3.1.0-py2.py3-none-any.whl (147 kB)
Collecting opt-einsum>=2.3.2
Using cached opt_einsum-3.3.0-py3-none-any.whl (65 kB)
Collecting packaging>=20.4
Downloading packaging-20.9-py2.py3-none-any.whl (40 kB)
|████████████████████████████████| 40 kB 2.5 MB/s
Collecting pandas>=0.25.0
Using cached pandas-1.2.2-cp37-cp37m-win_amd64.whl (9.1 MB)
Requirement already satisfied: locket in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from partd>=0.3.10->dask[dataframe]>=2.6.0->perceptilabs) (0.2.1)
Collecting protobuf>=3.6.1
Using cached protobuf-3.14.0-cp37-cp37m-win_amd64.whl (798 kB)
Collecting psutil>=5.6.3
Downloading psutil-5.8.0-cp37-cp37m-win_amd64.whl (244 kB)
|████████████████████████████████| 244 kB 3.2 MB/s
Collecting pygments>=2.6.1
Downloading Pygments-2.7.4-py3-none-any.whl (950 kB)
|████████████████████████████████| 950 kB 3.3 MB/s
Collecting PyJWT>=1.7.1
Using cached PyJWT-1.7.1-py2.py3-none-any.whl (18 kB)
Collecting pyparsing>=2.4.7
Downloading pyparsing-2.4.7-py2.py3-none-any.whl (67 kB)
|████████████████████████████████| 67 kB 3.0 MB/s
Collecting pyrsistent>=0.14.0
Downloading pyrsistent-0.17.3.tar.gz (106 kB)
|████████████████████████████████| 106 kB 6.4 MB/s
Collecting python-dateutil>=2.8.1
Downloading python_dateutil-2.8.1-py2.py3-none-any.whl (227 kB)
|████████████████████████████████| 227 kB 6.8 MB/s
Collecting pytz>=2019.3
Downloading pytz-2021.1-py2.py3-none-any.whl (510 kB)
|████████████████████████████████| 510 kB 6.8 MB/s
Collecting PyWavelets>=1.1.1
Using cached PyWavelets-1.1.1-cp37-cp37m-win_amd64.whl (4.2 MB)
Collecting pywin32>=223
Downloading pywin32-300-cp37-cp37m-win_amd64.whl (9.2 MB)
|████████████████████████████████| 9.2 MB 6.8 MB/s
Collecting pyyaml
Using cached PyYAML-5.4.1-cp37-cp37m-win_amd64.whl (210 kB)
Collecting pyzmq>=18.1.1
Downloading pyzmq-22.0.2-cp37-cp37m-win_amd64.whl (1.2 MB)
|████████████████████████████████| 1.2 MB 6.8 MB/s
Collecting requests>=2.24.0
Downloading requests-2.25.1-py2.py3-none-any.whl (61 kB)
|████████████████████████████████| 61 kB 3.8 MB/s
Collecting idna>=2.10
Downloading idna-2.10-py2.py3-none-any.whl (58 kB)
|████████████████████████████████| 58 kB 2.9 MB/s
Collecting requests-oauthlib>=1.2.0
Using cached requests_oauthlib-1.3.0-py2.py3-none-any.whl (23 kB)
Collecting scikit-learn>=0.22.1
Using cached scikit_learn-0.24.1-cp37-cp37m-win_amd64.whl (6.8 MB)
Collecting joblib>=0.11
Using cached joblib-1.0.1-py3-none-any.whl (303 kB)
Collecting scipy>=1.3.0
Using cached scipy-1.6.0-cp37-cp37m-win_amd64.whl (32.5 MB)
Collecting Send2Trash>=1.5.0
Downloading Send2Trash-1.5.0-py3-none-any.whl (12 kB)
Collecting six>=1.14.0
Downloading six-1.15.0-py2.py3-none-any.whl (10 kB)
Collecting termcolor>=1.1.0
Using cached termcolor-1.1.0-py3-none-any.whl
Collecting threadpoolctl>=2.0.0
Using cached threadpoolctl-2.1.0-py3-none-any.whl (12 kB)
Collecting tifffile>=2019.7.26
Using cached tifffile-2021.2.1-py3-none-any.whl (159 kB)
Collecting toolz>=0.8.2
Using cached toolz-0.11.1-py3-none-any.whl (55 kB)
Collecting typing-extensions>=3.6.4
Using cached typing_extensions-3.7.4.3-py3-none-any.whl (22 kB)
Collecting wcwidth>=0.1.9
Downloading wcwidth-0.2.5-py2.py3-none-any.whl (30 kB)
Collecting Werkzeug>=0.15
Using cached Werkzeug-1.0.1-py2.py3-none-any.whl (298 kB)
Collecting zipp>=3.1.0
Downloading zipp-3.4.0-py3-none-any.whl (5.2 kB)
Collecting cached-property
Using cached cached_property-1.5.2-py2.py3-none-any.whl (7.6 kB)
Collecting cloudpickle
Downloading cloudpickle-1.6.0-py3-none-any.whl (23 kB)
Requirement already satisfied: pyglet<=1.5.0,>=1.4.0 in c:\users\samuel.chambers\appdata\roaming\python\python37\site-packages (from gym->gym-unity>=0.20.0->perceptilabs) (1.5.0)
Collecting future
Using cached future-0.18.2-py3-none-any.whl
Collecting pycparser
Downloading pycparser-2.20-py2.py3-none-any.whl (112 kB)
|████████████████████████████████| 112 kB 6.4 MB/s
Building wheels for collected packages: pyrsistent
Building wheel for pyrsistent (setup.py) … done
Created wheel for pyrsistent: filename=pyrsistent-0.17.3-cp37-cp37m-win_amd64.whl size=70476 sha256=c94c944abd939fe576dc271bf94f0a6011fe96ae4bcaff5924919a9aa9cdec73
Stored in directory: c:\users\samuel.chambers\appdata\local\pip\cache\wheels\a5\52\bf\71258a1d7b3c8cbe1ee53f9314c6f65f20385481eaee573cc5
Successfully built pyrsistent
Installing collected packages: zipp, urllib3, typing-extensions, six, idna, chardet, requests, python-dateutil, pycparser, oauthlib, numpy, importlib-metadata, future, cached-property, Werkzeug, toolz, scipy, requests-oauthlib, pyyaml, pywin32, pytz, pyparsing, protobuf, MarkupSafe, markdown, kiwisolver, h5py, grpcio, decorator, cycler, cloudpickle, cffi, attrs, absl-py, tifffile, threadpoolctl, termcolor, PyWavelets, pyrsistent, PyJWT, pandas, opt-einsum, networkx, matplotlib, keras-preprocessing, keras-applications, joblib, jinja2, imageio, google-pasta, gast, dask, cryptography, click, astor, wcwidth, Send2Trash, scikit-learn, scikit-image, pyzmq, pygments, psutil, packaging, jsonschema
Successfully installed MarkupSafe-1.1.1 PyJWT-1.7.1 PyWavelets-1.1.1 Send2Trash-1.5.0 Werkzeug-1.0.1 absl-py-0.11.0 astor-0.8.1 attrs-20.3.0 cached-property-1.5.2 cffi-1.14.4 chardet-4.0.0 click-7.1.2 cloudpickle-1.6.0 cryptography-3.4.4 cycler-0.10.0 dask-2021.2.0 decorator-4.4.2 future-0.18.2 gast-0.2.2 google-pasta-0.2.0 grpcio-1.35.0 h5py-3.1.0 idna-2.10 imageio-2.9.0 importlib-metadata-3.4.0 jinja2-2.11.3 joblib-1.0.1 jsonschema-3.2.0 keras-applications-1.0.8 keras-preprocessing-1.1.2 kiwisolver-1.3.1 markdown-3.3.3 matplotlib-3.3.4 networkx-2.5 numpy-1.18.5 oauthlib-3.1.0 opt-einsum-3.3.0 packaging-20.9 pandas-1.2.2 protobuf-3.14.0 psutil-5.8.0 pycparser-2.20 pygments-2.7.4 pyparsing-2.4.7 pyrsistent-0.17.3 python-dateutil-2.8.1 pytz-2021.1 pywin32-300 pyyaml-5.4.1 pyzmq-22.0.2 requests-2.25.1 requests-oauthlib-1.3.0 scikit-image-0.17.2 scikit-learn-0.24.1 scipy-1.6.0 six-1.15.0 termcolor-1.1.0 threadpoolctl-2.1.0 tifffile-2021.2.1 toolz-0.11.1 typing-extensions-3.7.4.3 urllib3-1.25.10 wcwidth-0.2.5 zipp-3.4.0

(pl) C:\WINDOWS\system32>perceptilabs
‘perceptilabs’ is not recognized as an internal or external command,
operable program or batch file.

What should I do to fix this.
Thanks

Hi @samC, welcome. I’m just an overactive user, and I can’t directly answer your question but I would observe this:

I also use anaconda and my environments are in C:\Users\Julian\Anaconda3\envs, so when I start the Anaconda Prompt I see

(base) C:\Users\Julian

You said your environments are in

C:\ProgramData\Anaconda3\envs\pl

But your prompt is

(base) C:\WINDOWS\system32>

Is it possible there is an issue concerning where - root or env - the installation actually occurred? It’s odd because the response to your “perceptilabs” command is what I would expect from a Windows cmd prompt - not from conda. But in that case there’s no environment name.

C:\Users\Julian>perceptilabs
'perceptilabs' is not recognized as an internal or external command,
operable program or batch file.

I agree, you activated pl and then installed there so I’m puzzled too… you should have got something like this unless either a) install not where you thought or b) invisible bad character in “perceptilabs”?

(Perceptilabs-GPU) C:\Users\Julian>perceptilabs
PerceptiLabs: Starting
PerceptiLabs: PerceptiLabs Started
PerceptiLabs: PerceptiLabs is running at http://localhost:8080/?token=qYvEnFnozBYtAujH5bbPXlmkbfalv_NdOt-ZcoDVXHI
PerceptiLabs: Use Control-C to stop this server and shut down all PerceptiLabs processes.

I’d try a new Anaconda prompt, do conda env list to check environments, activate pl again and repeat.

(Maybe include some screenshots of the command windows if you can.)

HTH (but I accept it probably doesn’t)

I’ve tried new prompts in both run as administrator and not and restarted my PC to see if that would fix it for some reason and keep getting the same error. I have too much on this PC that could break to do a fresh install of anaconda and python, so I might give it a try on a different computer in a few days.

to be sure about the bad character I tried both typing it and copying it from the website. Idk if that would do anything lol.

I also added perceptilabs to the PATH. (I don’t really know what I’m doing I thought that might help maybe but it did not)

Just a clarification question even though I’m not in the same directory as you
(base) C:\Users\Julian
as compared to
(pl) C:\WINDOWS\system32>
If I installed it it should run the command ‘perceptilabs’ from anywhere correct?

(base) C:\Users\samuel.chambers>conda env list
# conda environments:
#
base                  *  C:\ProgramData\Anaconda3
pl                       C:\ProgramData\Anaconda3\envs\pl
GPU_ML                   C:\Users\samuel.chambers\.conda\envs\GPU_ML
GPU_ML_240               C:\Users\samuel.chambers\.conda\envs\GPU_ML_240
GPU_TF_ML                C:\Users\samuel.chambers\.conda\envs\GPU_TF_ML


(base) C:\Users\samuel.chambers>

This is the output from conda env list and its weird that this is the only env that I have created that is in program data besides the base. I also tried to create it from inside Anaconda Navigator and I’m getting the same error

I restarted perceptilabs based on a different environment and then changed directory so that I too was in C:\Windows\system32 - perceptilabs ran OK for me so that does not seem to be the issue.

Intuition (but no more than that) says that the location of your pl env is a problem. If you have an environment that you know works, you could try rebuilding a pl environment in the same area and then trying to run it.

If that doesn’t work, then I’m out of ideas. Good luck!

Julian

@samC One more thing… in your environment, if you type

>conda list "perceptilabs"

Does it show it as being installed?

My result for comparison: (use \ # to override markup)

# packages in environment at C:\Users\Julian\anaconda3\envs\Perceptilabs-GPU:
#
# Name Version Build Channel
perceptilabs-gpu 0.11.6.1 pypi_0 pypi

(and suddenly I see I am not up to date :slight_smile: my bad - I have occasionally been noting my build on various posts and got the cpu/gpu versions switched - sorry @robertl for any confusion, I have been using GPU exclusively for the last n weeks…)

PS Path modifications are certainly not necessary for Perceptilabs itself - at least, if you aim to start from within an Anaconda prompt. I have multiple installations (for CPU, GPU versions) so paths would not be helpful to me anyway.

2 Likes

It is not listed there or in pip list. That means it must not have installed correctly. Thanks I will have to try on another machine. maybe its due to priveledges or something

I think it is due to working in the “wrong” location, not privileges as such.

Anyway, glad we have identified the cause… now all you have to do is fix it :smiley:

You could try working within Anaconda to begin with, and then opening a command prompt in a newly created environment there, just to be on the safe side.

1 Like