Nodes preview doesn't render statistics\data

Hi @Loki - I wanted to try out TF 2.5 recently so this caught my eye because on this TF page it says

  • CUDA® Toolkit —TensorFlow supports CUDA® 11.2 (TensorFlow >= 2.5.0)

PL is only using TF2.4 at present, and my experience with a TF2.5 install is that there are package incompatibilities between TF2.5 dependencies and PL dependencies.

Does the problem persist if you use a cuda toolkit known to be compatible with TF2.4 and your OS, e.g. for me on Windows 10: 11.0.221 + cuDNN 8.0.5.39 ?

Pretty interesting. I have CUDA 11.2 while @Loki has 11.3.
both shouldn’t be compatible with TF2.4 in PL :face_with_raised_eyebrow:
Ok, so I will downgrade to Cuda toolkit 11.1 and see if it will work again.
BRB

let me keep this link here just for compatibility list between CUDA, CuDNN, TF, PL

https://www.tensorflow.org/install/source#gpu

Hey :wave:
Sorry for not returning to this topic yet, we have not managed to reproduce it properly on our end.

You mentioned that it was the latest update (0.12.8) where you noticed this issue @DrGM, and it was working fine just before?
Was it the same for you @Loki where it stopped working after an update and was working fine before then?

I believe @Loki also tried on a CPU only setup so it may not be related to the GPUs.

Hi @DrGM, would you be willing to share the log output you get when running PerceptiLabs in verbose mode?

I.e., run the tool as “perceptilabs -v=3” and then copy the full log output here.

Thanks for using the tool and sorry about the issues :slight_smile:

Hi,
yes it was working fine before the update.
however, after the update, downgrading didn’t solve the issue.

PL report.txt (81.7 KB)

Check attached report.

1 Like

Ok, what version did you have before updating? 0.12.7 or an older one?

I am not very sure, but it’s 7-8 months old as i don’t update regularly. probably in version 0.11.xx
but i can’t be sure.

**Side note: i downgraded CUDA toolkit to version 11.0 after clean installation.
now when i use command “nvidia-smi” i get cuda version 11.2
but when i use command “nvcc --version” i get cuda version 11.0

sorry, SOS, HELP! :sob: :sob:

Hmm, I’m not sure about the CUDA, looks like you got duplicate installations running? Maybe changing the environment variables can help.
For the PL error, would you mind trying two things?

  1. Press F12 to open the browser console, then press the Console tab at the top and send anything you see in there after the previews are not showing.
  2. Is your current installation inside an environment? Can you try creating a new environment and installing PL in that one, and then start up PL in any browser in Incognito/Private mode?

Someone else who had this issue managed to solve it by disabling some browser features:


Maybe something similar could help you?

I have already disabled this function, but with enabling it - all preview is disappear:


Also with cudnn and cudatools 11.0, 8.05 - it does not use GPU acceleration while training:
image

Hi Anton! I have logs too with similar issue:
output.txt (42.7 KB)

My steps:

  1. Run Perceptilabs -v=3
  2. Create MNIST model
  3. Open preview

I tried step 2 before step 1:

Step2:
I am not using environment. however I did use an environment now and suddenly “cudnn64_8.dll” showed as missing file in CMD.

2021-06-09 22:40:43.200162: W tensorflow/stream_executor/platform/default/dso_loader.cc:60] Could not load dynamic library ‘cudnn64_8.dll’; dlerror: cudnn64_8.dll not found
2021-06-09 22:40:43.200235: W tensorflow/core/common_runtime/gpu/gpu_device.cc:1757] Cannot dlopen some GPU libraries. Please make sure the missing libraries mentioned above are installed properly if you would like to use GPU. Follow the guide at https://www.tensorflow.org/install/gpu for how to download and setup the required libraries for your platform.
Skipping registering GPU devices…

Anyway, the PL opens with the same initial problem.
as for the step one of your recommendation:

Layout was forced before the page was fully loaded. If stylesheets are not yet loaded this may cause a flash of unstyled content. contentInject.js:5251:17

The script from “http://localhost:8080/static/js/app.12c5185cb4c1cd5596c9.js” was loaded even though its MIME type (“text/plain”) is not a valid JavaScript MIME type.

localhost:8080

The script from “http://localhost:8080/static/js/0.3f4117f65c7d6f13a74b.js” was loaded even though its MIME type (“text/plain”) is not a valid JavaScript MIME type.

localhost:8080

Loaded claygl, version 1.3.0 0.3f4117f65c7d6f13a74b.js:316:592686

Loaded echarts, version 4.9.0 0.3f4117f65c7d6f13a74b.js:316:592686

Ignoring unsupported entryTypes: layout-shift. logger-1.min.js:15:19831

Some cookies are misusing the recommended “SameSite“ attribute 6

Ignoring unsupported entryTypes: largest-contentful-paint. logger-1.min.js:15:17764

Ignoring unsupported entryTypes: longtask. logger-1.min.js:8:112829

No valid entryTypes; aborting registration. logger-1.min.js:8:112829

Use of drawWindow method from CanvasRenderingContext2D is deprecated. Use tabs.captureTab extensions API instead https://developer.mozilla.org/docs/Mozilla/Add-ons/WebExtensions/API/tabs/captureTab pagedata-script.js:1:5791

Loading failed for the with source “https://www.google-analytics.com/analytics.js”. localhost:8080:1:1

[KEYCLOAK] Usage of legacy style promise methods such as .error() and .success() has been deprecated and support will be removed in future versions. Use standard style promise methods such as .then() and .catch()` instead. 0.3f4117f65c7d6f13a74b.js:282:261

set network snapshot 0.3f4117f65c7d6f13a74b.js:282:261

Loading Worker from “http://localhost:8080/static/webworkers/calcChartBase.js” was blocked because of a disallowed MIME type (“text/plain”).

2 app

Loading Worker from “http://localhost:8080/static/webworkers/calcChartPic.js” was blocked because of a disallowed MIME type (“text/plain”).

app

Loading Worker from “http://localhost:8080/static/webworkers/calcChartBase.js” was blocked because of a disallowed MIME type (“text/plain”).

5 app

Loading Worker from “http://localhost:8080/static/webworkers/calcChartPic.js” was blocked because of a disallowed MIME type (“text/plain”).

app

Loading Worker from “http://localhost:8080/static/webworkers/calcChartBase.js” was blocked because of a disallowed MIME type (“text/plain”).

This webworker is blocked in ONLY firefox. Not blocked in Edge or chrome. thus it only shows the input nodes and Convolutions nodes.

this webworker for other nodes (other than the input and conv. nodes), is always blocked in any browser (Firefox, Edge, Chrome)


*Note: I downgraded my firefox from version 89 to version 85. still the same, both webworkers were blocked.

Appreciating your efforts solving this :laughing: :laughing:

I found a work around:
press windows logo+R
“regedit”
find: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes.js
change: Content Type: text/plain
to: Content Type: application/javascript

problem temporarily solved. works on firefox, but not working on chrome.

ref: https://github.com/golang/go/issues/32350

1 Like

Awesome that you found a workaround!!
We are still checking how to prevent it from our side :slight_smile:

@DrGM I sympathise. I’ve been there, and untangling it is a pain. It’s one reason I really only use cudatoolkit inside environments, using Anaconda to provide the cudatoolkit & cuDNN and then pip exclusively to install everything else.

I notice the different version reported by nvcc and that suggests to me a careful inspect of environment variables is in order; I think something is looking somewhere specific (hard coded? separate option in e…g. Visual Studio?) and something else is going via an environment variable…

But really, mostly just sympathy

1 Like

Great! Thank for the solution. It works for me!

1 Like

12.9 - works on Chrome too

2 Likes