Model doesnt seem to load in tests or exporter

After completing a 2 epochs in the trainer I closed out perceptilabs but forgot to re-export the model, upon restarting perceptilabs I cant seem to get the model to show up in tests & export screens.

I got this to happen in the current perceptilabs & pl-nightly (as of this date). Between the two releases they have little differences in symptoms but the end result is the same. Tests screen in pl-nightly will show a “new test” button which does nothing and sometimes will show a fully blank screen. Tests in (stable?) perceptilabs will show results of a last test but also does nothing with “new test” button. Both builds wont show model in the list table on the export screen.

Log doesnt seem to present any noticeable errors so im at as loss as to what’s going on, I even switched computation methods just to see if anything different would happen for fun but nope.

Any ideas?

Hi @RBR,
This issue sounds similar to this one: https://forum.perceptilabs.com/t/could-not-restart-training-from-scratch/768
We are currently having some issues with the checkpoint and model paths that’s causing the tool not to find if a model is trained in some situations, which likely is happening here if you are unable to find your model in those lists.
We will soon have a fix up for this in a new version, sorry about the issue!

Tests screen in pl-nightly will show a “new test” button which does nothing and sometimes will show a fully blank screen. Tests in (stable?) perceptilabs will show results of a last test but also does nothing with “new test” button

Also, if you happen to have screenshots for these, that would be very helpful :slight_smile: This sounds like something more is going wrong than just not showing the trained models in the dropdown.

I may have worded that poorly what I meant was the evaluation page, I also cant get pl-nightly to throw up a blank evaluation page after a PC restart so im not sure how these will help :smiley:

-Perceptilabs (stable)
image

-pl-nightly
image

Thanks! :smiley:
And if I understand it correctly, the only issue you face right now (since you no longer are hitting a blank page) is that after you press New Test (or Run Test) you don’t have your trained models in the dropdown?

All the issues are the same minus the blank page. No there is no dropdown, clicking the buttons do absolutely nothing/unresponsive in the evaluation page. As for the exporter there are no models listed.

Ok thanks for the clarification!
We are able to reproduce it and looking into it right now, sorry again for the inconvenience.

Some quickfixes for you:
If you press F12 to bring up the browser console, then press Application->IndexedDB->perceptilabs-idb->Delete Database->Refresh that could make the Run Test button work again.
If that does not work, then also remove the ~/User/.perceptilabs folder after having turned off PL (unless you are attached to your models).

Also, depending on which nightly you tried, you might not want to jump back and forth between the nightly and the current stable version, there is an incompatibility which may cause some bugs for you, so best to stick with one or the other at the moment :slight_smile:

Im not so concerned with evaluating anything it’s just something else I found along the way, It’s the export that im concerned with getting to work that way if something goes horribly wrong I can at least have what has been trained salvageable.

Edit: I tried the above instruction which I assume was for chrome but it didn’t yield any results.

So, I have some more info on this.
The paths are currently getting expanded wrong (especially if you are a Windows user) and your normal model folders may get placed in a different location than your model checkpoints.
You’ll find them under starting_path/~/Documents/Perceptilabs/Default

If you start PerceptiLabs in the same location every time then you should see your models and be able to export them, as it then also will find the checkpoints.

We’ll have a fix and automatically migrate everything so it’s working as soon as we can, hoping early to mid next week.

I seem to have fixed my issue, I deleted an older model that I setup from when I first started using perceptilabs (a vestige I dont use but never bothered to remove) and my newest now shows up in the exports and the dialogue dropdowns show up in evaluations. Only thing I can surmise from this is bad back compatibility with models created with older versions?

Some older models may have issues with the newer version, although we kept a close eye on compatibility during most of 0.12 as well as between 0.12 to 0.13.
Great that you got it working though! :slight_smile: