Issue with starting perceptilabs

So i have bee trying to make perceptilabs on my laptop for about a day now.
I’m just dipping my toes in this software.
I tried to run it with the installation instructions, on the getting started page.

The problem is that i get an openPLC login page in the start without a sign in option.
I am not able to create an account in the lab. Is there a way to fix this ?

this is the initial output, i think the program is running for sure. Its just the screen thats stopping me from going ahead.

Operations to perform:
  Apply all migrations: admin, api, auth, contenttypes, sessions
Running migrations:
  No migrations to apply.
PerceptiLabs: Starting
Performing system checks...

Performing system checks...

System check identified no issues (0 silenced).
February 16, 2021 - 11:19:42
Django version 3.1.6, using settings 'static_file_server.settings'
Starting development server at http://127.0.0.1:8080/
Quit the server with CONTROL-C.
Error: That port is already in use.
System check identified no issues (0 silenced).
February 16, 2021 - 11:19:42
Django version 3.1.6, using settings 'fileserver.settings'
Starting development server at http://127.0.0.1:8011/
Quit the server with CONTROL-C.
Performing system checks...

System check identified no issues (0 silenced).
February 16, 2021 - 11:19:43
Django version 3.1.6, using settings 'rygg.settings'
Starting development server at http://127.0.0.1:8000/
Quit the server with CONTROL-C.
WARNING:tensorflow:From /home/cpreet/anaconda3/envs/plabs/lib/python3.7/site-packages/tensorflow_core/python/compat/v2_compat.py:68: disable_resource_variables (from tensorflow.python.ops.variable_scope) is deprecated and will be removed in a future version.
Instructions for updating:
non-resource variables are not supported in the long term
PerceptiLabs: Waiting for services to listen on these ports:
PerceptiLabs:    kernel on port 5000
2021-02-16 16:49:44,880 - INFO - <string>:1 - Reporting errors with commit id: bd6ed8974267cd076d0f1e8cedd240829db71bc5
PerceptiLabs is ready...
2021-02-16 16:49:44,901 - INFO - <string>:1 - Trying to listen to: 0.0.0.0 5000
PerceptiLabs: PerceptiLabs Started
PerceptiLabs: PerceptiLabs is running at http://localhost:8080/?token=Ro25FBBNyCKHdN0c5OOYVKqArXLN8ALWh1FQ25vmbyw
PerceptiLabs: Use Control-C to stop this server and shut down all PerceptiLabs processes.
  • made the virtual environment with conda
conda create -n plabs python=3.7

then activated it

conda activate plabs
  • Installed the package
pip install perceptilabs
  • start program
perceptilabs

Hi @cpreet,
Welcome to the forum!

It looks like you may have another service (like OpenPLC) already running on port 8080.
You can run this before you start PerceptiLabs to ensure that no ports are blocked:
netstat -a -n -o | find "8080"
netstat -a -n -o | find "8000"
netstat -a -n -o | find "8011"
netstat -a -n -o | find "5000"
If any of them return something, you want to kill that service before starting PerceptiLabs.

Hope that helps!
All the best,
Robert

Yes, I thought i had removed that software from my system. Turns out, it has been in the autostar menu from the time i had first installed it, even after a regular cleanup. Time for a reinstall. Anyway what worked was

systemctl stop openplc
systemctl disable openplc 

Started perceptilabs after this and it worked as intended.

Thanks for solving. :smile:

1 Like