Failed to get convolution algorithm

Im trying out perceptilabs for the first time and when i go to train anything i get the same error

“tensorflow.python.framework.errors_impl.UnknownError: Failed to get convolution algorithm. This is probably because cuDNN failed to initialize, so try looking to see if a warning log message was printed above. [Op:Conv2D]”

I’ve tried things like reinstalling cuda and python and i keep getting the same message

Hi @NiccoK

I had the same issue in the past, which is why I put together some cuda runbooks in the forum. The setup for v0.12 with TF 2.4 is a bit different but I also think I noted some compatible versions elsewhere in the forum.

Apart from that, can you say whether you are installing cuda globally or in an environment? (And what is your OS - I have experience of Windows but not Linux)

My recommendation is to install in the environment using Anaconda… if that’s not what you have tried, please give that a go. If that is what you have been trying, please can you say a bit more about e.g. the cudatoolkit, cuDNN versions you have tried (they’re not all compatible), etc.

Let us know if this helps.