I thought I’d update everything by building a new environment, including TF2.5.
Alas, close but no cigar…
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts. tensorflow-gpu 2.5.0 requires gast==0.4.0, but you have gast 0.3.3 which is incompatible. tensorflow-gpu 2.5.0 requires grpcio~=1.34.0, but you have grpcio 1.32.0 which is incompatible. tensorflow-gpu 2.5.0 requires h5py~=3.1.0, but you have h5py 2.10.0 which is incompatible. tensorflow-gpu 2.5.0 requires tensorflow-estimator<2.6.0,>=2.5.0rc0, but you have tensorflow-estimator 2.4.0 which is incompatible.
and PL installation downgrades urllib3, numpy, Pillow, grpcio, decorator, colorama, h5py, gast.
I must confess I have never looked into dependency management or how dependencies are determined so I would like to understand that and maybe why these are real dependencies.
Just for example: you require numpy 1.19.2 rather than the latest 1.19.5 and I really don’t see that there could/should be incompatibilities in version changes in the 3rd place, and usually incompatibilities are signalled by major version number changes.
Is there anything that can be done to mitigate these issues so that e.g. TF2.5 can be used?