Can't use Perceptilabs after update

Hi,

After updating PL, the page keeps refreshing every 5 seconds or so. I ran perceptilabs -v=3 and here is what it shows me. Is there a way to fix this? I am using Brave as my browser. It was working fine before the update, but does tell me that the app service is unavailable.

Also this:

and this:

Interestingly, it doesn’t happen in Firefox.

Hey @JWalker,
Strange that it stopped working after the update, is it the 0.13.1 update you are referring to or 0.13.0?

Does it also tell you that the app service is unavailable in FireFox or just in Brave?

We’ll take a look at the logs :slight_smile:

By the looks of it, it might help by clearing the browser cache in Brave. It seems to be trying to update an invalid token every 6 seconds.

Thanks Robert,

This is 13.1, I assume because the gui refresh was 13.0 I guess.

No, in Firefox I don’t get the complaint about the app service; however, I used to get this in Brave prior to the update and it worked just fine. I ran a model in Firefox and it worked exactly as expected, so this is not a big problem. I cleared the entire cache from Brave, but I still have the problem.

Ok thanks for the update!
We’ll keep looking at the Brave logs you sent, but I’m glad it works with FireFox for you :slight_smile:

1 Like

Hi @robertl,

I am now having the same problem in Firefox; however, this time I know that it started immediately after the Firefox update. So, I have uninstall and reinstalled Firefox, that hasn’t worked. I have also removed the environment containing PL and then reinstalled PL; that hasn’t worked.

Consequently, I can’t convince PL to work in either Brave/Chrome or Firefox. I will install basic Chrome and see if that works, but I will be running out of browsers soon.

Here are the screenshots of the PL logs.

1 2

I am a genius!

Solved it. After the update, you need to log out and log in again. PL will auto login and I think that refresh every 6 seconds is something to do with that.

Hi @JWalker,
I’m glad to hear that you solved it! :smiley:

Strange that you had to log out and log in again, we did recently do an update (over a week ago) on the login server in an attempt to solve the issue you were having, which had seemed to work without logging in and out on our side.
Let me know if you ever encounter it again and we will jump on it straight away :slight_smile:

1 Like