Can't Load Data

Hi, I was able to successfully install all dependencies, but I can’t load data at all in the UI.

Data was able to load:
image

But I can never select data:
image

It won’t let me select local data as well.

I have a couple bad requests with mixpanel:
ID removed in a few places.

perceptilabs -v=3
2021-08-03 08:40:35.573135: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cudart64_110.dll
2021-08-03 08:40:38.716743: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library nvcuda.dll
2021-08-03 08:40:38.754195: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1733] Found device 0 with properties:
pciBusID: 0000:01:00.0 name: Quadro T1000 with Max-Q Design computeCapability: 7.5
coreClock: 1.5GHz coreCount: 14 deviceMemorySize: 4.00GiB deviceMemoryBandwidth: 149.04GiB/s
2021-08-03 08:40:38.754923: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cudart64_110.dll
2021-08-03 08:40:38.767451: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cublas64_11.dll
2021-08-03 08:40:38.767838: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cublasLt64_11.dll
2021-08-03 08:40:38.777491: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cufft64_10.dll
2021-08-03 08:40:38.779889: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library curand64_10.dll
2021-08-03 08:40:38.784062: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cusolver64_11.dll
2021-08-03 08:40:38.790717: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cusparse64_11.dll
2021-08-03 08:40:38.792496: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cudnn64_8.dll
2021-08-03 08:40:38.792911: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1871] Adding visible gpu devices: 0
Operations to perform:
Apply all migrations: admin, api, auth, contenttypes, sessions
Running migrations:
No migrations to apply.
PerceptiLabs: Starting
2021-08-03 08:40:41.391457: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cudart64_110.dll
2021-08-03 08:40:41.393191: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cudart64_110.dll
Performing system checks…

Performing system checks…

System check identified no issues (0 silenced).
August 03, 2021 - 08:40:42
Django version 3.2, using settings ‘static_file_server.settings’
Starting development server at http://127.0.0.1:8080/
Quit the server with CTRL-BREAK.
System check identified no issues (0 silenced).
August 03, 2021 - 08:40:42
Django version 3.2, using settings ‘rygg.settings’
Starting development server at http://127.0.0.1:8000/
Quit the server with CTRL-BREAK.
[03/Aug/2021 08:40:44] “GET /?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 200 493
[03/Aug/2021 08:40:44] “GET /rygg_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:44] “GET /is_enterprise HTTP/1.1” 200 28
[03/Aug/2021 08:40:44] “GET /rendering_kernel_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:44] “GET /kernel_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:44] 2021-08-03 08:40:44.503118: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library nvcuda.dll
“GET /is_enterprise HTTP/1.1” 200 28
2021-08-03 08:40:44.522119: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library nvcuda.dll
2021-08-03 08:40:44.551919: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1733] Found device 0 with properties:
pciBusID: 0000:01:00.0 name: Quadro T1000 with Max-Q Design computeCapability: 7.5
coreClock: 1.5GHz coreCount: 14 deviceMemorySize: 4.00GiB deviceMemoryBandwidth: 149.04GiB/s
2021-08-03 08:40:44.552737: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cudart64_110.dll
2021-08-03 08:40:44.561946: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cublas64_11.dll
2021-08-03 08:40:44.562220: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cublasLt64_11.dll
2021-08-03 08:40:44.568208: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cufft64_10.dll
2021-08-03 08:40:44.569559: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1733] Found device 0 with properties:
pciBusID: 0000:01:00.0 name: Quadro T1000 with Max-Q Design computeCapability: 7.5
coreClock: 1.5GHz coreCount: 14 deviceMemorySize: 4.00GiB deviceMemoryBandwidth: 149.04GiB/s
2021-08-03 08:40:44.570193: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cudart64_110.dll
2021-08-03 08:40:44.570399: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library curand64_10.dll
2021-08-03 08:40:44.573222: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cusolver64_11.dll
2021-08-03 08:40:44.577820: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cusparse64_11.dll
2021-08-03 08:40:44.579472: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cudnn64_8.dll
2021-08-03 08:40:44.579614: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cublas64_11.dll
2021-08-03 08:40:44.579923: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1871] Adding visible gpu devices: 0
2021-08-03 08:40:44.580240: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cublasLt64_11.dll
2021-08-03 08:40:44.586226: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cufft64_10.dll
2021-08-03 08:40:44.588154: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library curand64_10.dll
2021-08-03 08:40:44.590952: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cusolver64_11.dll
2021-08-03 08:40:44.595077: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cusparse64_11.dll
2021-08-03 08:40:44.596614: I tensorflow/stream_executor/platform/default/dso_loader.cc:53] Successfully opened dynamic library cudnn64_8.dll
2021-08-03 08:40:44.597012: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1871] Adding visible gpu devices: 0
[03/Aug/2021 08:40:44] “GET /keycloak_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:44] “GET /keycloak_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “GET /?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 200 493
[03/Aug/2021 08:40:45] “GET /is_enterprise HTTP/1.1” 200 28
[03/Aug/2021 08:40:45] “GET /rygg_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “GET /rendering_kernel_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “GET /kernel_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “GET /is_enterprise HTTP/1.1” 200 28
[03/Aug/2021 08:40:45] “GET /keycloak_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “GET /keycloak_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “GET /rygg_url HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “GET /is_enterprise HTTP/1.1” 200 28
[03/Aug/2021 08:40:45] “OPTIONS /app/updates_available/?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “OPTIONS /projects/?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “OPTIONS /app/version?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “GET /app/version?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 301 0
[03/Aug/2021 08:40:45] “OPTIONS /app/version/?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 200 0
[03/Aug/2021 08:40:45] “GET /projects/?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 200 309
[03/Aug/2021 08:40:45] “GET /app/version/?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 200 22
Bad Request: /mixpanel/decide/
[03/Aug/2021 08:40:46] “GET /mixpanel/decide/?verbose=1&version=1&lib=web&token=1480b2244fdd4d821227a29e2637f922&ip=1&=1627998045734 HTTP/1.1" 400 28
Bad Request: /mixpanel/track/
[03/Aug/2021 08:40:46] "POST /mixpanel/track/?ip=1&
=1627998045740 HTTP/1.1” 400 23
[03/Aug/2021 08:40:46] “GET /app/updates_available/?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84 HTTP/1.1” 200 22
2021-08-03 08:40:46,915 - INFO - perceptilabs_main_:4 - Started kernel in mode ‘training’
2021-08-03 08:40:46,922 - INFO - perceptilabs_main_:4 - Started kernel in mode ‘rendering’
2021-08-03 08:40:47,580 - INFO - perceptilabs_main_:4 - Reporting errors with commit id: a650eca0f210983e83652e10b5ab6b7c2d5663b0
PerceptiLabs is ready…
2021-08-03 08:40:47,616 - INFO - perceptilabs_main_:4 - Trying to listen to: 0.0.0.0 5000
2021-08-03 08:40:47,632 - INFO - :219 - Initialized sentry for environment ‘production’ and release ‘0.12.17’
2021-08-03 08:40:47,679 - INFO - app.py:1857 - Request to endpoint 'version
INFO:perceptilabs.applogger:Request to endpoint 'version
PerceptiLabs: PerceptiLabs Started2021-08-03 08:40:47,681 - INFO - app.py:1884 - Request to endpoint ‘version’ took 0.0003s

INFO:perceptilabs.applogger:Request to endpoint ‘version’ took 0.0003s
PerceptiLabs: PerceptiLabs is running at http://localhost:8080/?token=mK1cbqorZLVwM2dbpJxITWLsb4U9v5n2gTsa2oTOK84
PerceptiLabs: Use Control-C to stop this server and shut down all PerceptiLabs processes.
2021-08-03 08:40:47,686 - INFO - app.py:1857 - Request to endpoint 'version
INFO:perceptilabs.applogger:Request to endpoint 'version
2021-08-03 08:40:47,687 - INFO - app.py:1884 - Request to endpoint ‘version’ took 0.0002s
INFO:perceptilabs.applogger:Request to endpoint ‘version’ took 0.0002s
2021-08-03 08:40:47,975 - INFO - server.py:293 - Frontend receiver: None , Frontend request: isRunning
2021-08-03 08:40:47,976 - INFO - server.py:293 - Created coreLogic for network ‘None’
2021-08-03 08:40:48,287 - INFO - server.py:293 - Frontend receiver: , Frontend request: setUser
2021-08-03 08:40:48,288 - INFO - server.py:293 - Created coreLogic for network ‘’
2021-08-03 08:40:48,289 - INFO - server.py:293 - User has been set to
Bad Request: /mixpanel/decide/
Bad Request: /mixpanel/engage/
Bad Request: /mixpanel/engage/
[03/Aug/2021 08:40:50] “GET /mixpanel/decide/?verbose=1&version=3&lib=web&token=1480b2244fdd4d821227a29e2637f922&distinct_id=&ip=1&=1627998050612 HTTP/1.1" 400 28
[03/Aug/2021 08:40:50] "POST /mixpanel/engage/?ip=1&
=1627998050616 HTTP/1.1” 400 23
[03/Aug/2021 08:40:50] “POST /mixpanel/engage/?ip=1&_=1627998050615 HTTP/1.1” 400 23

Hi @mccartycp,
Welcome to the forum!

From the first look of it I can’t see any issues in the logs, I do however notice that the filechooser does not show the path to the folder you are in (in the image).
This typically happens when one of the services are being blocked or not working as it should.
The issue is that you can’t double click into any of the folders, correct?

Some standard things you can test:

  • Does it work better if you use another browser?
  • Make sure that nothing is blocking the ports before starting PL by running:
    netstat -a -n -o | find "8080"
    netstat -a -n -o | find "8000"
    netstat -a -n -o | find "5000"
  • Are you running through any virtualization and how does your setup look like?
  • When you installed, did you install it in a fresh Anaconda environment?

All the best,
Robert